Moodle LTI module reflected XSS risk
The advisory, in context
A reflected XSS issue was identified in the LTI module of Moodle. The vulnerability exists due to insufficient sanitization of user-supplied data in the LTI module. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks. This vulnerability does not impact authenticated users.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 4.0 before 4.0.2
Fixed in 4.0.2
7 explicitly affected versions
v4.0.0, v4.0.0-beta, v4.0.0-rc1, v4.0.0-rc2, v4.0.0-rc3, v4.0.0-rc4, v4.0.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0"
},
{
"fixed": "4.0.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.0.0",
"v4.0.0-beta",
"v4.0.0-rc1",
"v4.0.0-rc2",
"v4.0.0-rc3",
"v4.0.0-rc4",
"v4.0.1"
]
}From 3.11 before 3.11.8
Fixed in 3.11.8
11 explicitly affected versions
v3.11.0, v3.11.0-beta, v3.11.0-rc1, v3.11.0-rc2, v3.11.1, v3.11.2, v3.11.3, v3.11.4, v3.11.5, v3.11.6, v3.11.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.11"
},
{
"fixed": "3.11.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.11.0",
"v3.11.0-beta",
"v3.11.0-rc1",
"v3.11.0-rc2",
"v3.11.1",
"v3.11.2",
"v3.11.3",
"v3.11.4",
"v3.11.5",
"v3.11.6",
"v3.11.7"
]
}From 3.9 before 3.9.15
Fixed in 3.9.15
19 explicitly affected versions
v3.9.0, v3.9.0-beta, v3.9.0-rc1, v3.9.0-rc2, v3.9.0-rc3, v3.9.1, v3.9.10, v3.9.11, v3.9.12, v3.9.13, v3.9.14, v3.9.2, v3.9.3, v3.9.4, v3.9.5, v3.9.6, v3.9.7, v3.9.8, v3.9.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.9"
},
{
"fixed": "3.9.15"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.9.0",
"v3.9.0-beta",
"v3.9.0-rc1",
"v3.9.0-rc2",
"v3.9.0-rc3",
"v3.9.1",
"v3.9.10",
"v3.9.11",
"v3.9.12",
"v3.9.13",
"v3.9.14",
"v3.9.2",
"v3.9.3",
"v3.9.4",
"v3.9.5",
"v3.9.6",
"v3.9.7",
"v3.9.8",
"v3.9.9"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2022-35653
- https://bugzilla.redhat.com/show_bug.cgi?id=2106277
- https://github.com/moodle/moodle
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/6MOKYVRNFNAODP2XSMGJ5CRDUZCZKAR3
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MTKUSFPSYFINSQFSOHDQIDVE6FWBEU6V
- https://moodle.org/mod/forum/discuss.php?d=436460
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-72299