Cross site-scripting (XSS) moodle
The advisory, in context
The filter in the tag manager required extra sanitizing to prevent a reflected XSS risk. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 3.9.0 before 3.9.2
Fixed in 3.9.2
2 explicitly affected versions
v3.9.0, v3.9.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.9.0"
},
{
"fixed": "3.9.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.9.0",
"v3.9.1"
]
}From 3.8.0 before 3.8.5
Fixed in 3.8.5
5 explicitly affected versions
v3.8.0, v3.8.1, v3.8.2, v3.8.3, v3.8.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.8.0"
},
{
"fixed": "3.8.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.8.0",
"v3.8.1",
"v3.8.2",
"v3.8.3",
"v3.8.4"
]
}From 3.7.0 before 3.7.8
Fixed in 3.7.8
8 explicitly affected versions
v3.7.0, v3.7.1, v3.7.2, v3.7.3, v3.7.4, v3.7.5, v3.7.6, v3.7.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.7.0"
},
{
"fixed": "3.7.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.7.0",
"v3.7.1",
"v3.7.2",
"v3.7.3",
"v3.7.4",
"v3.7.5",
"v3.7.6",
"v3.7.7"
]
}From 3.5 before 3.5.14
Fixed in 3.5.14
16 explicitly affected versions
v3.5.0, v3.5.0-beta, v3.5.0-rc1, v3.5.1, v3.5.10, v3.5.11, v3.5.12, v3.5.13, v3.5.2, v3.5.3, v3.5.4, v3.5.5, v3.5.6, v3.5.7, v3.5.8, v3.5.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.5"
},
{
"fixed": "3.5.14"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.5.0",
"v3.5.0-beta",
"v3.5.0-rc1",
"v3.5.1",
"v3.5.10",
"v3.5.11",
"v3.5.12",
"v3.5.13",
"v3.5.2",
"v3.5.3",
"v3.5.4",
"v3.5.5",
"v3.5.6",
"v3.5.7",
"v3.5.8",
"v3.5.9"
]
}