GHSA-5wx6-xwxf-q8qjmedium4.6
Cross-Site Scripting in TYPO3 Backend
No CVE assignedCheck your stack
The advisory, in context
Failing to properly encode user input, some backend components are vulnerable to Cross-Site Scripting. A valid backend user account is needed to exploit this vulnerability.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
typo3/cms Packagist
Ecosystem versions
From 6.2.0 before 6.2.20
Fixed in 6.2.20
21 explicitly affected versions
6.2.0, 6.2.1, 6.2.10, 6.2.10-rc1, 6.2.11, 6.2.12, 6.2.13, 6.2.14, 6.2.15, 6.2.16, 6.2.17, 6.2.18, 6.2.19, 6.2.2, 6.2.3, 6.2.4, 6.2.5, 6.2.6, 6.2.7, 6.2.8, 6.2.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.2.0"
},
{
"fixed": "6.2.20"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"6.2.0",
"6.2.1",
"6.2.10",
"6.2.10-rc1",
"6.2.11",
"6.2.12",
"6.2.13",
"6.2.14",
"6.2.15",
"6.2.16",
"6.2.17",
"6.2.18",
"6.2.19",
"6.2.2",
"6.2.3",
"6.2.4",
"6.2.5",
"6.2.6",
"6.2.7",
"6.2.8",
"6.2.9"
]
}typo3/cms Packagist
Ecosystem versions
From 7.6.0 before 7.6.5
Fixed in 7.6.5
5 explicitly affected versions
7.6.0, 7.6.1, 7.6.2, 7.6.3, 7.6.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.6.0"
},
{
"fixed": "7.6.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"7.6.0",
"7.6.1",
"7.6.2",
"7.6.3",
"7.6.4"
]
}typo3/cms Packagist
Ecosystem versions
From 8.0.0 before 8.0.1
Fixed in 8.0.1
1 explicitly affected versions
8.0.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "8.0.0"
},
{
"fixed": "8.0.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"8.0.0"
]
}