Moodle stored Cross-site Scripting
The advisory, in context
ID numbers displayed in the quiz grading report required additional sanitizing to prevent a stored XSS risk. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 3.5 before 3.5.18
Fixed in 3.5.18
20 explicitly affected versions
v3.5.0, v3.5.0-beta, v3.5.0-rc1, v3.5.1, v3.5.10, v3.5.11, v3.5.12, v3.5.13, v3.5.14, v3.5.15, v3.5.16, v3.5.17, v3.5.2, v3.5.3, v3.5.4, v3.5.5, v3.5.6, v3.5.7, v3.5.8, v3.5.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.5"
},
{
"fixed": "3.5.18"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.5.0",
"v3.5.0-beta",
"v3.5.0-rc1",
"v3.5.1",
"v3.5.10",
"v3.5.11",
"v3.5.12",
"v3.5.13",
"v3.5.14",
"v3.5.15",
"v3.5.16",
"v3.5.17",
"v3.5.2",
"v3.5.3",
"v3.5.4",
"v3.5.5",
"v3.5.6",
"v3.5.7",
"v3.5.8",
"v3.5.9"
]
}From 3.8 before 3.8.9
Fixed in 3.8.9
11 explicitly affected versions
v3.8.0, v3.8.0-beta, v3.8.0-rc1, v3.8.1, v3.8.2, v3.8.3, v3.8.4, v3.8.5, v3.8.6, v3.8.7, v3.8.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.8"
},
{
"fixed": "3.8.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.8.0",
"v3.8.0-beta",
"v3.8.0-rc1",
"v3.8.1",
"v3.8.2",
"v3.8.3",
"v3.8.4",
"v3.8.5",
"v3.8.6",
"v3.8.7",
"v3.8.8"
]
}From 3.9 before 3.9.7
Fixed in 3.9.7
11 explicitly affected versions
v3.9.0, v3.9.0-beta, v3.9.0-rc1, v3.9.0-rc2, v3.9.0-rc3, v3.9.1, v3.9.2, v3.9.3, v3.9.4, v3.9.5, v3.9.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.9"
},
{
"fixed": "3.9.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.9.0",
"v3.9.0-beta",
"v3.9.0-rc1",
"v3.9.0-rc2",
"v3.9.0-rc3",
"v3.9.1",
"v3.9.2",
"v3.9.3",
"v3.9.4",
"v3.9.5",
"v3.9.6"
]
}From 3.10 before 3.10.4
Fixed in 3.10.4
7 explicitly affected versions
v3.10.0, v3.10.0-beta, v3.10.0-rc1, v3.10.0-rc2, v3.10.1, v3.10.2, v3.10.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.10"
},
{
"fixed": "3.10.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.10.0",
"v3.10.0-beta",
"v3.10.0-rc1",
"v3.10.0-rc2",
"v3.10.1",
"v3.10.2",
"v3.10.3"
]
}