GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Check your stack
GHSA-5w2h-59j3-8x5whigh7.2

TYPO3 Install Tool vulnerable to Code Execution

Impact

Several settings in the Install Tool for configuring the path to system binaries were vulnerable to code execution. Exploiting this vulnerability requires an administrator-level backend user account with system maintainer permissions.

Source excerpt · OSV
Applies when

Exploiting this vulnerability requires an administrator-level backend user account with system maintainer permissions.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Affected rangeRecorded fix
From 8.0.0 before 8.7.57Ecosystem versions8.7.57
From 9.0.0 before 9.5.46Ecosystem versions9.5.46
From 10.0.0 before 10.4.43Ecosystem versions10.4.43
From 11.0.0 before 11.5.35Ecosystem versions11.5.35
From 12.0.0 before 12.4.11Ecosystem versions12.4.11
From 13.0.0 before 13.0.1Ecosystem versions13.0.1

Version evidence: OSV · GHSA-5w2h-59j3-8x5w

View original version evidence (174 explicit versions)

Original source description

Problem

Several settings in the Install Tool for configuring the path to system binaries were vulnerable to code execution. Exploiting this vulnerability requires an administrator-level backend user account with system maintainer permissions.

The corresponding change for this advisory involves enforcing the known disadvantages described in TYPO3-PSA-2020-002: Protecting Install Tool with Sudo Mode.

Solution

Update to TYPO3 versions 8.7.57 ELTS, 9.5.46 ELTS, 10.4.43 ELTS, 11.5.35 LTS, 12.4.11 LTS, 13.0.1 that fix the problem described.

Credits

Thanks to Rickmer Frier & Daniel Jonka who reported this issue and to TYPO3 core & security team member Benjamin Franzke who fixed the issue.

References

References