GHSA-5qj8-6xxj-hp9hmedium5.3
Dompdf before v2.0.0 vulnerable to chroot check bypass
The advisory, in context
Dompdf prior to version 2.0.0 is vulnerable to a chroot check bypass, which could cause disclosure of png and jpeg files.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
dompdf/dompdf Packagist
Ecosystem versions
Earlier releases before 2.0.0
Fixed in 2.0.0
22 explicitly affected versions
v0.6.0, v0.6.1, v0.6.2, v0.7.0, v0.7.0-beta, v0.7.0-beta2, v0.7.0-beta3, v0.8.0, v0.8.1, v0.8.2, v0.8.3, v0.8.4, v0.8.5, v0.8.6, v1.0.0, v1.0.1, v1.0.2, v1.1.0, v1.1.1, v1.2.0, v1.2.1, v1.2.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v0.6.0",
"v0.6.1",
"v0.6.2",
"v0.7.0",
"v0.7.0-beta",
"v0.7.0-beta2",
"v0.7.0-beta3",
"v0.8.0",
"v0.8.1",
"v0.8.2",
"v0.8.3",
"v0.8.4",
"v0.8.5",
"v0.8.6",
"v1.0.0",
"v1.0.1",
"v1.0.2",
"v1.1.0",
"v1.1.1",
"v1.2.0",
"v1.2.1",
"v1.2.2"
]
}