GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

All vulnerabilities
GHSA-5q4q-834j-g8g4high8.5

Paymenter has URL parameter injection that bypasses paid plan limits at checkout

Check your stack

The advisory, in context

Summary

The checkout component improperly filters URL-writable properties, allowing authenticated users to inject arbitrary key-value pairs into server provisioning parameters. Because bundled server extensions prioritize these user-supplied properties over administrator-defined configurations, a regular user can override hosting plans and resource limits at checkout without special privileges.

Technical Details

The Checkout Livewire component (app/Livewire/Products/Checkout.php) exposes the $checkoutConfig property to URL query parameters via the #[Url] attribute (aliased as config).

When processing this input:

  1. Validation rules are dynamically generated only for keys explicitly defined by an extension's getCheckoutConfig() method. Any undefined keys injected into the query parameter bypass validation entirely.
  2. The cart component (app/Livewire/Cart.php) stores all keys from checkout_config directly into the database without sanitation:
   foreach ($item->checkout_config as $key => $value) {
       $service->properties()->updateOrCreate(['key' => $key], ['value' => $value]);
   }
  1. During server provisioning, app/Helpers/ExtensionHelper.php retrieves these stored properties and passes them to the extension's createServer() method.

Because of how individual server extensions handle these properties, user-injected data overrides intended administrator settings.

Impact

This is a business logic flaw that allows remote, authenticated users to manipulate server provisioning parameters.

Depending on the active extension, this leads to unauthorized overrides of core resource limits (such as CPU, RAM, storage, or package tiers). No administrative privileges are required to exploit this vulnerability.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

Earlier releases before 1.5.1

Fixed in 1.5.1

32 explicitly affected versions

0.1, 0.1.1, 0.1.2, 0.1.3, 0.2, 0.2.1, v0.3, v0.4, v0.4.1, v0.5, v0.5.1, v0.5.2, v0.5.3, v0.6, v0.7, v0.7.1, v0.8, v0.8.1, v0.8.2, v0.9, v0.9.1, v0.9.2, v0.9.3, v0.9.4, v0.9.5, v1.0.0, v1.0.1, v1.0.2, v1.0.3, v1.0.4, v1.1.0, v1.1.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "1.5.1"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "0.1",
    "0.1.1",
    "0.1.2",
    "0.1.3",
    "0.2",
    "0.2.1",
    "v0.3",
    "v0.4",
    "v0.4.1",
    "v0.5",
    "v0.5.1",
    "v0.5.2",
    "v0.5.3",
    "v0.6",
    "v0.7",
    "v0.7.1",
    "v0.8",
    "v0.8.1",
    "v0.8.2",
    "v0.9",
    "v0.9.1",
    "v0.9.2",
    "v0.9.3",
    "v0.9.4",
    "v0.9.5",
    "v1.0.0",
    "v1.0.1",
    "v1.0.2",
    "v1.0.3",
    "v1.0.4",
    "v1.1.0",
    "v1.1.1"
  ]
}

References