GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-5hvg-w58j-545mmedium5.4

Mautic has Stored Cross-Site Scripting (XSS) in Project Option Selector

Check your stack

The advisory, in context

Summary

A stored Cross-Site Scripting (XSS) vulnerability exists in the project selector component of Mautic 7. When rendering selection menus for associating projects with system entities, the application fails to sanitize project names returned via AJAX before injecting them into the DOM as option fields. An authenticated user with permissions to create projects can exploit this to store a malicious script payload in the project's name.

Impact

When another administrative user subsequently opens an entity editor containing the project selector, the injected script executes within the context of their active browser session. This could allow an attacker to hijack the session, perform unauthorized state coordination, or access organizational data within the dashboard.

Patched Versions

This security issue has been addressed in the following release:

  • 7.1.2

Note: Mautic 6.x, 5.x, and 4.x branches do not contain the Projects feature or the associated AJAX selector and are not affected by this vulnerability. For general security support regarding legacy Mautic 4 releases, please refer to the ELTS page.

Workarounds

There are no official workarounds. To mitigate this vulnerability without upgrading, restrict project creation and modification permissions to trusted administrative users.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

mautic/core Packagist
Ecosystem versions

From 7.0.0 before 7.1.2

Fixed in 7.1.2

6 explicitly affected versions

7.0.0, 7.0.1, 7.0.2, 7.1.0, 7.1.0-rc, 7.1.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "7.0.0"
        },
        {
          "fixed": "7.1.2"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "7.0.0",
    "7.0.1",
    "7.0.2",
    "7.1.0",
    "7.1.0-rc",
    "7.1.1"
  ]
}

References