GHSA-5fj7-f8x3-q2mchigh7.5
simpleSAMLphp incorrectly handles XML encryption
The advisory, in context
simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt or forge messages.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
simplesamlphp/simplesamlphp Packagist
Ecosystem versions
Earlier releases before 1.8.1
Fixed in 1.8.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.8.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2011-4625
- https://github.com/simplesamlphp/simplesamlphp
- https://github.com/simplesamlphp/simplesamlphp/blob/b3059c51a915910c6631fb2ee597c0fb6ad9162b/docs/simplesamlphp-changelog-1.x.md?plain=1#L1624
- https://secure1.securityspace.com/smysecure/catid.html?in=DSA%202330-1
- https://security-tracker.debian.org/tracker/CVE-2011-4625
- https://www.mageni.net/vulnerability/debian-security-advisory-dsa-2330-1-simplesamlphp-70545