GHSA-5ffj-mph5-c5hvmedium5.4
Appwrite Vulnerable to Cross-site Scripting
The advisory, in context
Appwrite is vulnerable to stored cross-site scripting in usernames, function names, storage bucket names, and database collection names.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
appwrite/server-ce Packagist
Ecosystem versions
Earlier releases before 1.0.0-RC1
Fixed in 1.0.0-RC1
46 explicitly affected versions
0.1.13, 0.1.15, 0.10.0, 0.10.1, 0.10.2, 0.10.3, 0.10.4, 0.11.0, 0.11.1, 0.11.2, 0.12.0, 0.12.1, 0.12.2, 0.12.3, 0.12.4, 0.13.0, 0.13.1, 0.13.2, 0.13.3, 0.13.4, 0.14.0, 0.14.1, 0.14.2, 0.15.0, 0.15.1, 0.15.2, 0.15.3, 0.2.0, 0.3.0, 0.4.0, 0.5.0, 0.5.1, 0.5.2, 0.5.3, 0.6.0, 0.6.1, 0.6.2, 0.7.0, 0.7.1, 0.7.2, 0.8.0, 0.9, 0.9.1, 0.9.2, 0.9.3, 0.9.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.0.0-RC1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.1.13",
"0.1.15",
"0.10.0",
"0.10.1",
"0.10.2",
"0.10.3",
"0.10.4",
"0.11.0",
"0.11.1",
"0.11.2",
"0.12.0",
"0.12.1",
"0.12.2",
"0.12.3",
"0.12.4",
"0.13.0",
"0.13.1",
"0.13.2",
"0.13.3",
"0.13.4",
"0.14.0",
"0.14.1",
"0.14.2",
"0.15.0",
"0.15.1",
"0.15.2",
"0.15.3",
"0.2.0",
"0.3.0",
"0.4.0",
"0.5.0",
"0.5.1",
"0.5.2",
"0.5.3",
"0.6.0",
"0.6.1",
"0.6.2",
"0.7.0",
"0.7.1",
"0.7.2",
"0.8.0",
"0.9",
"0.9.1",
"0.9.2",
"0.9.3",
"0.9.4"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2022-2925
- https://github.com/appwrite/appwrite/commit/b5b4d92623c13fa8e5c71736db461e81fb7a7ade
- https://drive.google.com/file/d/1JoMQy1KTodVtIVOzH3vKcC3AwZz0PrFb/view?usp=sharing
- https://github.com/appwrite/appwrite
- https://huntr.dev/bounties/a3b4148f-165f-4583-abed-5568696d99dc