GHSA-59x4-67mh-px54medium5.3
Crypt_GPG does not prevent additional options in GPG calls
The advisory, in context
The Crypt_GPG extension before 1.6.7 for PHP does not prevent additional options in GPG calls, which presents a risk for certain environments and GPG versions.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
pear/crypt_gpg Packagist
Ecosystem versions
Earlier releases before 1.6.7
Fixed in 1.6.7
14 explicitly affected versions
v1.4.0, v1.4.1, v1.4.2, v1.4.3, v1.6.0, v1.6.0b1, v1.6.0b2, v1.6.0b3, v1.6.1, v1.6.2, v1.6.3, v1.6.4, v1.6.5, v1.6.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.6.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v1.4.0",
"v1.4.1",
"v1.4.2",
"v1.4.3",
"v1.6.0",
"v1.6.0b1",
"v1.6.0b2",
"v1.6.0b3",
"v1.6.1",
"v1.6.2",
"v1.6.3",
"v1.6.4",
"v1.6.5",
"v1.6.6"
]
}