GHSA-58w4-w77w-qv3whigh8.7
Reflected XSS with parameters in PostComment
The advisory, in context
Impact
An attacker could inject malicious web code into the users' web browsers by creating a malicious link.
Patches
The problem is fixed in 4.2.0
References
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
prestashop/productcomments Packagist
Ecosystem versions
From 4.0.0 before 4.2.0
Fixed in 4.2.0
3 explicitly affected versions
v4.0.0, v4.0.1, v4.1.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0.0"
},
{
"fixed": "4.2.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.0.0",
"v4.0.1",
"v4.1.0"
]
}