GHSA-5834-xv5q-cgfwmedium5.4
Shopware vulnerable to persistent cross site scripting (XSS) in customer module
Impact
Persistent XSS in customer module
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
shopware/shopware Packagist
| Affected range | Recorded fix |
|---|---|
| From 5.7.0 before 5.7.14Ecosystem versions | 5.7.14 |
Version evidence: OSV · GHSA-5834-xv5q-cgfw
View original version evidence (14 explicit versions)
Original source description
Impact
Persistent XSS in customer module
Patches
We recommend updating to the current version 5.7.14. You can get the update to 5.7.14 regularly via the Auto-Updater or directly via the download overview.
For older versions you can use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html
References
https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-07-2022
References
- Security advisory github.com/shopware/shopware/security/advisories/GHSA-5834-xv5q-cgfw
- Security advisory nvd.nist.gov/vuln/detail/CVE-2022-31148
- Patch github.com/shopware/shopware/commit/7875855005648fba7b39371a70816afae2e07daf
- Security advisory docs.shopware.com/en/shopware-5-en/security-updates/security-update-07-2022
- Source reference github.com/shopware/shopware
- Release notes www.shopware.com/en/changelog-sw5/