GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Check your stack
GHSA-57f2-8p89-66x6medium4.2

Kirby vulnerable to self cross-site scripting (self-XSS) in the URL field

Impact

This vulnerability affects Kirby sites that use the URL field in any blueprint.

Source excerpt · OSV
Applies when

A successful attack commonly requires knowledge of the content structure by the attacker as well as social engineering of a user with access to the Panel.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

getkirby/cms Packagist
Affected rangeRecorded fix
Earlier releases before 3.6.6.5Ecosystem versions3.6.6.5
From 3.7.0 before 3.7.5.4Ecosystem versions3.7.5.4
From 3.8.0 before 3.8.4.3Ecosystem versions3.8.4.3
From 3.9.0 before 3.9.8.1Ecosystem versions3.9.8.1
From 3.10.0 before 3.10.0.1Ecosystem versions3.10.0.1
From 4.0.0 before 4.1.1Ecosystem versions4.1.1

Version evidence: OSV · GHSA-57f2-8p89-66x6

View original version evidence (177 explicit versions)

Original source description

TL;DR

This vulnerability affects Kirby sites that use the URL field in any blueprint.

A successful attack commonly requires knowledge of the content structure by the attacker as well as social engineering of a user with access to the Panel. The attack cannot be automated.

The vulnerability is also limited to self-XSS and cannot directly affect other users or visitors of the site.


Introduction

Cross-site scripting (XSS) is a type of vulnerability that allows to execute any kind of JavaScript code inside the Panel session of the same or other users. In the Panel, a harmful script can for example trigger requests to Kirby's API with the permissions of the victim.

Self cross-site scripting (self-XSS, also called reflected XSS) typically involves a user inadvertently executing malicious code within their own context, often through social engineering techniques. This can occur when a user is tricked into pasting and executing malicious JavaScript code into the browser's developer console, address bar or form fields.

Such vulnerabilities are critical as they allow attackers to gain access to the system or to escalate their privileges if they get access to the Panel session of an admin user. Depending on your site, other JavaScript-powered attacks are possible.

Impact

The URL field allows users to open the entered link in a new tab by clicking the link icon inside the field. This can be used to quickly verify whether the entered URL is functional and correct.

In affected versions, Kirby copied the entered URL into the link target of that link button without validating or sanitizing the link. This could be abused by attackers with a javascript: URL that would then be executed in the user's context when the link button was clicked with <kbd>Ctrl+Click</kbd>/<kbd>Cmd+Click</kbd>.

Patches

The problem has been patched in Kirby 3.6.6.5, Kirby 3.7.5.4, Kirby 3.8.4.3, Kirby 3.9.8.1, Kirby 3.10.0.1, and Kirby 4.1.1. Please update to one of these or a later version to fix the vulnerability.

In all of the mentioned releases, we have changed the URL field to only make the link button clickable if the entered URL is valid and safe.

Credits

Thanks to Natwara Archeepsamooth (@PlyNatwara) for responsibly reporting the identified issue.

References