GHSA-55g3-fjwm-w2c8high8.7
TYPO3 Color Picker Wizard component allows remote authenticated editors to execute arbitrary PHP code
The advisory, in context
The Color Picker Wizard component in TYPO3 4.5.0 before 4.5.34, 4.7.0 before 4.7.19, 6.0.0 before 6.0.14, and 6.1.0 before 6.1.9 allows remote authenticated editors to execute arbitrary PHP code via a serialized PHP object.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
typo3/cms Packagist
Ecosystem versions
From 4.5.0 before 4.5.34
Fixed in 4.5.34
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.5.0"
},
{
"fixed": "4.5.34"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms Packagist
Ecosystem versions
From 4.7.0 before 4.7.19
Fixed in 4.7.19
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.7.0"
},
{
"fixed": "4.7.19"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms Packagist
Ecosystem versions
From 6.0.0 before 6.0.14
Fixed in 6.0.14
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.0.0"
},
{
"fixed": "6.0.14"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms Packagist
Ecosystem versions
From 6.1.0 before 6.1.9
Fixed in 6.1.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.1.0"
},
{
"fixed": "6.1.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2014-3942
- https://github.com/TYPO3/typo3
- https://typo3.org/security/advisory/typo3-core-sa-2014-001
- http://lists.opensuse.org/opensuse-updates/2014-06/msg00037.html
- http://www.debian.org/security/2014/dsa-2942
- http://www.openwall.com/lists/oss-security/2014/06/03/2