GHSA-4xh9-5vh8-3p58medium6.1
Yii Framework Reflected XSS
The advisory, in context
Reflected Cross-site scripting (XSS) vulnerability in Yii Framework before 2.0.11, when development mode is used, allows remote attackers to inject arbitrary web script or HTML via crafted request data that is mishandled on the debug-mode exception screen.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
yiisoft/yii2 Packagist
Ecosystem versions
Earlier releases before 2.0.11
Fixed in 2.0.11
14 explicitly affected versions
2.0.0, 2.0.0-alpha, 2.0.0-beta, 2.0.0-rc, 2.0.1, 2.0.10, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.0.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.11"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.0.0",
"2.0.0-alpha",
"2.0.0-beta",
"2.0.0-rc",
"2.0.1",
"2.0.10",
"2.0.2",
"2.0.3",
"2.0.4",
"2.0.5",
"2.0.6",
"2.0.7",
"2.0.8",
"2.0.9"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2017-7271
- https://github.com/yiisoft/yii2/pull/13401
- https://github.com/yiisoft/yii2/commit/97171a0db7cda0a49931ee0c3b998ef50bd06756
- https://github.com/yiisoft/yii2
- https://web.archive.org/web/20210125191138/http://www.securityfocus.com/bid/97167
- http://www.yiiframework.com/news/123/yii-2-0-11-is-released