GHSA-4w6c-3hcx-rfj5medium4.8
MantisBT vulnerable to XSS through config_option parameter in adm_config_report.php
The advisory, in context
A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (adm_config_report.php) allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted 'config_option' parameter. This is fixed in 1.3.9, 2.1.3, and 2.2.3.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
mantisbt/mantisbt Packagist
Ecosystem versions
Earlier releases before 1.3.9
Fixed in 1.3.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.3.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}mantisbt/mantisbt Packagist
Ecosystem versions
From 2.1.0 before 2.1.3
Fixed in 2.1.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.1.0"
},
{
"fixed": "2.1.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}mantisbt/mantisbt Packagist
Ecosystem versions
From 2.2.0 before 2.2.3
Fixed in 2.2.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.2.0"
},
{
"fixed": "2.2.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2017-7309
- https://github.com/mantisbt/mantisbt/commit/0243375e32bc24878e309f3d6ef6d8cfb3e2f278
- https://github.com/mantisbt/mantisbt/commit/c9e5b1d0404503022605459552faeaf610bf15ae
- https://github.com/mantisbt/mantisbt/commit/e881dd79df422033bbea88914fc0a717fae40358
- https://github.com/mantisbt/mantisbt
- http://openwall.com/lists/oss-security/2017/03/30/4
- http://www.mantisbt.org/bugs/view.php?id=22579