Moodle Cross-site Scripting (XSS)
The advisory, in context
A vulnerability was found in Moodle 3.9 to 3.9.1, 3.8 to 3.8.4 and 3.7 to 3.7.7 where it was possible to include JavaScript in a book's chapter title, which was not escaped on the "Add new chapter" page. This is fixed in 3.9.2, 3.8.5 and 3.7.8.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 3.9 before 3.9.2
Fixed in 3.9.2
6 explicitly affected versions
v3.9.0, v3.9.0-beta, v3.9.0-rc1, v3.9.0-rc2, v3.9.0-rc3, v3.9.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.9"
},
{
"fixed": "3.9.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.9.0",
"v3.9.0-beta",
"v3.9.0-rc1",
"v3.9.0-rc2",
"v3.9.0-rc3",
"v3.9.1"
]
}From 3.8 before 3.8.5
Fixed in 3.8.5
7 explicitly affected versions
v3.8.0, v3.8.0-beta, v3.8.0-rc1, v3.8.1, v3.8.2, v3.8.3, v3.8.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.8"
},
{
"fixed": "3.8.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.8.0",
"v3.8.0-beta",
"v3.8.0-rc1",
"v3.8.1",
"v3.8.2",
"v3.8.3",
"v3.8.4"
]
}From 3.7 before 3.7.8
Fixed in 3.7.8
11 explicitly affected versions
v3.7.0, v3.7.0-beta, v3.7.0-rc1, v3.7.0-rc2, v3.7.1, v3.7.2, v3.7.3, v3.7.4, v3.7.5, v3.7.6, v3.7.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.7"
},
{
"fixed": "3.7.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.7.0",
"v3.7.0-beta",
"v3.7.0-rc1",
"v3.7.0-rc2",
"v3.7.1",
"v3.7.2",
"v3.7.3",
"v3.7.4",
"v3.7.5",
"v3.7.6",
"v3.7.7"
]
}