OroCommerce Cross site scripting vulnerability during shipping rule editing for UPS integration
The advisory, in context
Impact
Shipping rule edit page is vulnerable to cross site scripting (XSS) payload added to UPS Surcharge field. The attacker should have permission to create or edit a shipping rule.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 4.1.0 before 5.0.6
Fixed in 5.0.6
44 explicitly affected versions
4.1.0, 4.1.1, 4.1.1-rc, 4.1.1-rc2, 4.1.10, 4.1.11, 4.1.12, 4.1.13, 4.1.2, 4.1.3, 4.1.4, 4.1.5, 4.1.6, 4.1.7, 4.1.8, 4.1.9, 4.2.0, 4.2.0-alpha, 4.2.0-alpha.1, 4.2.0-alpha.2, 4.2.0-alpha.3, 4.2.0-beta, 4.2.0-rc, 4.2.1, 4.2.10, 4.2.2, 4.2.3, 4.2.4, 4.2.5, 4.2.6, 4.2.7, 4.2.8, 4.2.9, 5.0.0, 5.0.0-alpha.1, 5.0.0-alpha.2, 5.0.0-beta.1, 5.0.0-beta.2, 5.0.0-rc, 5.0.1, 5.0.2, 5.0.3, 5.0.4, 5.0.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.1.0"
},
{
"fixed": "5.0.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.1.0",
"4.1.1",
"4.1.1-rc",
"4.1.1-rc2",
"4.1.10",
"4.1.11",
"4.1.12",
"4.1.13",
"4.1.2",
"4.1.3",
"4.1.4",
"4.1.5",
"4.1.6",
"4.1.7",
"4.1.8",
"4.1.9",
"4.2.0",
"4.2.0-alpha",
"4.2.0-alpha.1",
"4.2.0-alpha.2",
"4.2.0-alpha.3",
"4.2.0-beta",
"4.2.0-rc",
"4.2.1",
"4.2.10",
"4.2.2",
"4.2.3",
"4.2.4",
"4.2.5",
"4.2.6",
"4.2.7",
"4.2.8",
"4.2.9",
"5.0.0",
"5.0.0-alpha.1",
"5.0.0-alpha.2",
"5.0.0-beta.1",
"5.0.0-beta.2",
"5.0.0-rc",
"5.0.1",
"5.0.2",
"5.0.3",
"5.0.4",
"5.0.5"
]
}