GHSA-4v57-pwvf-x35jmedium6.1
Zendframework potential Cross-site Scripting vector in `Zend_Service_ReCaptcha_MailHide`
No CVE assignedCheck your stack
The advisory, in context
Zend_Service_ReCaptcha_MailHide had a potential XSS vulnerability. Due to the fact that the email address was never validated, and because its use of htmlentities() did not include the encoding argument, it was potentially possible for a malicious user aware of the issue to inject a specially crafted multibyte string as an attack via the CAPTCHA's email argument
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
zendframework/zendframework1 Packagist
Ecosystem versions
From 1.7.0 before 1.7.9
Fixed in 1.7.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.7.0"
},
{
"fixed": "1.7.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}zendframework/zendframework1 Packagist
Ecosystem versions
From 1.8.0 before 1.8.5
Fixed in 1.8.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.8.0"
},
{
"fixed": "1.8.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}zendframework/zendframework1 Packagist
Ecosystem versions
From 1.9.0 before 1.9.7
Fixed in 1.9.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.9.0"
},
{
"fixed": "1.9.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}