Scramble vulnerable to remote code execution via evaluation of user-controlled input in validation rules
The advisory, in context
Impact
A remote code execution (RCE) vulnerability affects versions 0.13.2 through 0.13.21. When documentation endpoints are publicly accessible and validation rules reference user-controlled input, request supplied data may be evaluated during documentation generation, leading to execution of arbitrary PHP code in the application context.
Patches
Fixed in version 0.13.22.
Workarounds
If upgrading is not immediately possible:
- Restrict access to documentation endpoints (
/docs/api,/docs/api.json) - Avoid using user-controlled variables inside validation rule expressions (e.g., values derived from request input)
- Disable documentation endpoints in production environments if not required
These measures significantly reduce or prevent exploitability.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 0.13.2 before 0.13.22
Fixed in 0.13.22
20 explicitly affected versions
v0.13.10, v0.13.11, v0.13.12, v0.13.13, v0.13.14, v0.13.15, v0.13.16, v0.13.17, v0.13.18, v0.13.19, v0.13.2, v0.13.20, v0.13.21, v0.13.3, v0.13.4, v0.13.5, v0.13.6, v0.13.7, v0.13.8, v0.13.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0.13.2"
},
{
"fixed": "0.13.22"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v0.13.10",
"v0.13.11",
"v0.13.12",
"v0.13.13",
"v0.13.14",
"v0.13.15",
"v0.13.16",
"v0.13.17",
"v0.13.18",
"v0.13.19",
"v0.13.2",
"v0.13.20",
"v0.13.21",
"v0.13.3",
"v0.13.4",
"v0.13.5",
"v0.13.6",
"v0.13.7",
"v0.13.8",
"v0.13.9"
]
}