GHSA-4qgh-m9vp-48xphigh8.8
MunkiReport Software Update module is vulnerable to SQL injection
The advisory, in context
A SQL injection vulnerability in softwareupdate_controller.php in the Software Update module before 1.6 for MunkiReport allows attackers to execute arbitrary SQL commands via the last URL parameter of the /module/softwareupdate/get_tab_data/ endpoint.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
munkireport/softwareupdate Packagist
Ecosystem versions
Earlier releases before 1.6
Fixed in 1.6
7 explicitly affected versions
v1.1, v1.2, v1.2.1, v1.2.2, v1.3, v1.4, v1.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v1.1",
"v1.2",
"v1.2.1",
"v1.2.2",
"v1.3",
"v1.4",
"v1.5"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2020-15887
- https://github.com/munkireport/munkireport-php/releases
- https://github.com/munkireport/munkireport-php/releases/tag/v5.6.3
- https://github.com/munkireport/munkireport-php/wiki/20200722-SQL-Injection-in-softwareupdate-module
- https://github.com/munkireport/softwareupdate
- https://github.com/munkireport/softwareupdate/releases