GHSA-4j8w-p6hv-3qxcmedium4.3
Cross-Site Request Forgery (CSRF) in automad/automad
The advisory, in context
automad up to 1.10.9 does not implement anti-CSRF tokens by default, making it vulnerable Cross-Site Request Forgery (CSRF). An attacker may exploit this vulnerability to force an admin into creating or deleting users. An exploit has been disclosed publicly.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
automad/automad Packagist
Ecosystem versions
Earlier releases before 2.0.0-alpha.1
Fixed in 2.0.0-alpha.1
1 explicitly affected versions
1.10.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.0-alpha.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.10.9"
]
}