silverstripe restfulserver and registry modules SQL injection vulnerability
The advisory, in context
SQL injection vulnerability in silverstripe/restfulserver module 1.0.x before 1.0.9, 2.0.x before 2.0.4, and 2.1.x before 2.1.2 and silverstripe/registry module 2.1.x before 2.1.1 and 2.2.x before 2.2.1 allows attackers to execute arbitrary SQL commands.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 2.1.0 before 2.1.2
Fixed in 2.1.2
2 explicitly affected versions
2.1.0, 2.1.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.1.0"
},
{
"fixed": "2.1.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.1.0",
"2.1.1"
]
}From 2.1.0 before 2.1.1
Fixed in 2.1.1
1 explicitly affected versions
2.1.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.1.0"
},
{
"fixed": "2.1.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.1.0"
]
}From 2.2.0 before 2.2.1
Fixed in 2.2.1
1 explicitly affected versions
2.2.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.2.0"
},
{
"fixed": "2.2.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.2.0"
]
}From 1.0.0 before 1.0.9
Fixed in 1.0.9
9 explicitly affected versions
1.0.1, 1.0.1-rc1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.0.0"
},
{
"fixed": "1.0.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0.1",
"1.0.1-rc1",
"1.0.2",
"1.0.3",
"1.0.4",
"1.0.5",
"1.0.6",
"1.0.7",
"1.0.8"
]
}From 2.0.0 before 2.0.4
Fixed in 2.0.4
4 explicitly affected versions
2.0.0, 2.0.1, 2.0.2, 2.0.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.0.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.0.0",
"2.0.1",
"2.0.2",
"2.0.3"
]
}