GHSA-4h2q-84w7-4mhxmedium5.8
nilsteampassnet/teampass vulnerable to stored cross-site scripting (XSS)
The advisory, in context
nilsteampassnet/teampass prior to 3.0.3 is vulnerable to stored cross-site scripting (XSS) in the description parameter of a folder.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
nilsteampassnet/teampass Packagist
Ecosystem versions
Earlier releases before 3.0.3
Fixed in 3.0.3
6 explicitly affected versions
2.1.21, 2.1.26, 2.1.27, 3.0.0, 3.0.0.10, 3.0.0.11
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.1.21",
"2.1.26",
"2.1.27",
"3.0.0",
"3.0.0.10",
"3.0.0.11"
]
}