GHSA-4cv2-xc5f-px8hmedium5.0
Denial of Service in extension "Code Highlight" (codehighlight)
No CVE assignedCheck your stack
The advisory, in context
The codehighlight extension bundles a vulnerable version of the 3rd party JavaScript component “prism” which is known to be vulnerable against Regular expression Denial of Service (ReDoS).
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
brotkrueml/codehighlight Packagist
Ecosystem versions
Earlier releases before 2.5.0
Fixed in 2.5.0
10 explicitly affected versions
v1.0.0, v1.0.1, v1.1.0, v1.1.1, v2.0.0, v2.0.1, v2.1.0, v2.2.0, v2.3.0, v2.4.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.5.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v1.0.0",
"v1.0.1",
"v1.1.0",
"v1.1.1",
"v2.0.0",
"v2.0.1",
"v2.1.0",
"v2.2.0",
"v2.3.0",
"v2.4.0"
]
}References
- https://github.com/brotkrueml/codehighlight/commit/c2f05e5200f1562a3fba2de1f12ee9872f883e2c
- https://github.com/FriendsOfPHP/security-advisories/blob/master/brotkrueml/codehighlight/2021-03-16-1.yaml
- https://github.com/brotkrueml/codehighlight
- https://typo3.org/security/advisory/typo3-ext-sa-2021-002