GHSA-4c64-w8fg-xcq2medium6.1
Yii Cross-site Scripting Framework vulnerability
The advisory, in context
An XSS vulnerability exists in framework/views/errorHandler/exception.php in Yii Framework 2.0.12 affecting the exception screen when debug mode is enabled, because $exception->errorInfo is mishandled.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
yiisoft/yii2-dev Packagist
Ecosystem versions
From 2.0.12 before 2.0.13
Fixed in 2.0.13
3 explicitly affected versions
2.0.12, 2.0.12.1, 2.0.12.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0.12"
},
{
"fixed": "2.0.13"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.0.12",
"2.0.12.1",
"2.0.12.2"
]
}yiisoft/yii2 Packagist
Ecosystem versions
From 2.0.12 before 2.0.13
Fixed in 2.0.13
3 explicitly affected versions
2.0.12, 2.0.12.1, 2.0.12.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0.12"
},
{
"fixed": "2.0.13"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.0.12",
"2.0.12.1",
"2.0.12.2"
]
}