GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-4c2w-v5rq-5mx7medium

eZ Platform Editor Cross-site Scripting (XSS)

No CVE assignedCheck your stack

The advisory, in context

This Security Advisory is about two issues of low to medium severity. We recommend that you install the update as soon as possible.

There is an XSS vulnerability in CKEditor, which is used by AlloyEditor, which is used in eZ Platform Admin UI. Scripts can be injected through specially crafted "protected" comments. We are not sure it is exploitable in eZ Platform, but recommend installing it to be on the safe side. It is fixed in CKEditor v4.14, AlloyEditor v2.11.9. It is distributed via Composer, for:

eZ Platform v1.13.x: ezsystems/PlatformUIAssetsBundle v4.2.3 (included from ezsystems/PlatformUIBundle v1.13.x) eZ Platform v2.5.13: ezsystems/ezplatform-admin-ui-assets v4.2.1 eZ Platform v3.0.*: ezsystems/ezplatform-admin-ui-assets v5.0.1 eZ Platform v3.1.2: ezsystems/ezplatform-admin-ui-assets v5.1.1

Drafts that are sent to trash become visible in the Review Queue, even for users that were not able to see them before this action. It's not possible to preview them, but their title and review history is displayed. This affects Enterprise Edition only, of which ezplatform-workflow is a part. This security update is distributed via Composer, for

eZ Platform EE v2.5.13: ezsystems/ezplatform-workflow v1.1.9 eZ Platform EE v3.1.2: ezsystems/ezplatform-workflow v2.1.1

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

From 4.2.0 before 4.2.1

Fixed in 4.2.1

1 explicitly affected versions

v4.2.0

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "4.2.0"
        },
        {
          "fixed": "4.2.1"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v4.2.0"
  ]
}
Ecosystem versions

From 5.0.0 before 5.0.1

Fixed in 5.0.1

1 explicitly affected versions

v5.0.0

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "5.0.0"
        },
        {
          "fixed": "5.0.1"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v5.0.0"
  ]
}
Ecosystem versions

From 5.1.0 before 5.1.1

Fixed in 5.1.1

1 explicitly affected versions

v5.1.0

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "5.1.0"
        },
        {
          "fixed": "5.1.1"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v5.1.0"
  ]
}

References