GHSA-49fj-qp6p-q544critical9.8
Variable Tampering within joomla/input class
The advisory, in context
An issue was discovered in Joomla! 4.0.0 through 4.1.0. Under specific circumstances, JInput pollutes method-specific input bags with $_REQUEST data.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
joomla/input Packagist
Ecosystem versions
From 2.0.0 before 2.0.2
Fixed in 2.0.2
2 explicitly affected versions
2.0.0, 2.0.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.0.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.0.0",
"2.0.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2022-23799
- https://github.com/joomla/joomla-cms/issues/35541
- https://github.com/joomla-framework/input/commit/2086df5860a2edccd77c329ee7cbd118cfe93514
- https://developer.joomla.org/security-centre/876-20220307-core-variable-tampering-on-jinput-request-data.html
- https://github.com/FriendsOfPHP/security-advisories/blob/master/joomla/input/CVE-2022-23799.yaml
- https://github.com/joomla-framework/input