GHSA-48r9-4v93-x4whhigh
DOMPDF Remote File Inclusion Vulnerability
The advisory, in context
PHP remote file inclusion vulnerability in dompdf.php in dompdf 0.6.0 beta1 allows remote attackers to execute arbitrary PHP code via a URL in the input_file parameter.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
dompdf/dompdf Packagist
Ecosystem versions
From 0.6 before 0.6.1
Fixed in 0.6.1
1 explicitly affected versions
v0.6.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0.6"
},
{
"fixed": "0.6.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v0.6.0"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2010-4879
- https://github.com/dompdf/dompdf/commit/23a693993299e669306929e3d49a4a1f7b3fb028
- https://github.com/FriendsOfPHP/security-advisories/blob/master/dompdf/dompdf/CVE-2010-4879.yaml
- https://github.com/dompdf/dompdf
- https://github.com/dompdf/dompdf/releases/tag/v0.6.2
- https://github.com/dompdf/dompdf/wiki/Securing-dompdf
- http://www.exploit-db.com/exploits/14851