GHSA-48p3-xfvw-g59cmedium5.3
Incorrect Access Control in ImpressCMS
The advisory, in context
ImpressCMS before 1.4.3 has Incorrect Access Control because include/findusers.php allows access by unauthenticated attackers (who are, by design, able to have a security token).
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
impresscms/impresscms Packagist
Ecosystem versions
Earlier releases before 1.4.3
Fixed in 1.4.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.4.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2021-26598
- https://github.com/ImpressCMS/impresscms/pull/967
- https://hackerone.com/reports/1081137
- https://github.com/ImpressCMS/impresscms
- https://github.com/ImpressCMS/impresscms/releases/tag/v1.4.3
- https://packetstormsecurity.com/files/166403/ImpressCMS-1.4.2-Incorrect-Access-Control.html
- http://karmainsecurity.com/KIS-2022-03
- http://seclists.org/fulldisclosure/2022/Mar/45