GHSA-47ww-mq32-g4xwmedium6.3
TYPO3 vulnerable to Insecure Unserialize via Content Editing Wizards component
The advisory, in context
The Content Editing Wizards component in TYPO3 4.5.0 through 4.5.31, 4.7.0 through 4.7.16, 6.0.0 through 6.0.11, and 6.1.0 through 6.1.6 allows remote authenticated backend users to unserialize arbitrary PHP objects, delete arbitrary files, and possibly have other unspecified impacts via an unspecified parameter, related to a "missing signature."
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
typo3/cms Packagist
Ecosystem versions
From 4.5.0 before 4.5.32
Fixed in 4.5.32
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.5.0"
},
{
"fixed": "4.5.32"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms Packagist
Ecosystem versions
From 4.7.0 before 4.7.17
Fixed in 4.7.17
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.7.0"
},
{
"fixed": "4.7.17"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms Packagist
Ecosystem versions
From 6.0.0 before 6.0.12
Fixed in 6.0.12
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.0.0"
},
{
"fixed": "6.0.12"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms Packagist
Ecosystem versions
From 6.1.0 before 6.1.7
Fixed in 6.1.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.1.0"
},
{
"fixed": "6.1.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}