GHSA-47mc-qmh2-mqj4medium6.8
Automad arbitrary file upload vulnerability
The advisory, in context
An arbitrary file upload vulnerability in the image upload function of Automad v2.0.0 allows attackers to execute arbitrary code via a crafted file.
The malicious file has to be prepared and uploaded manually by the admin. Usually there is only one admin per site and that is the owner.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
automad/automad Packagist
Ecosystem versions
Earlier releases before 2.0.0-alpha.5
Fixed in 2.0.0-alpha.5
5 explicitly affected versions
1.10.9, 2.0.0-alpha.1, 2.0.0-alpha.2, 2.0.0-alpha.3, 2.0.0-alpha.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.0-alpha.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.10.9",
"2.0.0-alpha.1",
"2.0.0-alpha.2",
"2.0.0-alpha.3",
"2.0.0-alpha.4"
]
}