Magento 2 Community Edition RCE Vulnerability
Impact
A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with system data manipulation privileges can execute aribitrary code through arbitrary file deletion and OS command injection.
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
| Affected range | Recorded fix |
|---|---|
| From 2.2 before 2.2.10Ecosystem versions | 2.2.10 |
| From 2.3 before 2.3.2-p2Ecosystem versions | 2.3.2-p2 |
Version evidence: OSV · GHSA-47h6-hfpv-7phj
View original version evidence (13 explicit versions)
Original source description
A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with system data manipulation privileges can execute aribitrary code through arbitrary file deletion and OS command injection.
As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.
References
- Security advisory nvd.nist.gov/vuln/detail/CVE-2019-8159
- Security advisory github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8159.yaml
- Security advisory magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update
- Security advisory web.archive.org/web/20220121051105/https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update