GHSA-47cw-whh9-j2fqmedium
Moodle allows attacks to obtain sensitive information
The advisory, in context
lib/phpunit/bootstrap.php in Moodle 2.6.x before 2.6.6 and 2.7.x before 2.7.3 allows remote attackers to obtain sensitive information via a direct request, which reveals the full path in an error message.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
moodle/moodle Packagist
Ecosystem versions
From 2.6.0 before 2.6.6
Fixed in 2.6.6
6 explicitly affected versions
v2.6.0, v2.6.1, v2.6.2, v2.6.3, v2.6.4, v2.6.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.6.0"
},
{
"fixed": "2.6.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.6.0",
"v2.6.1",
"v2.6.2",
"v2.6.3",
"v2.6.4",
"v2.6.5"
]
}moodle/moodle Packagist
Ecosystem versions
From 2.7.0 before 2.7.3
Fixed in 2.7.3
3 explicitly affected versions
v2.7.0, v2.7.1, v2.7.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.7.0"
},
{
"fixed": "2.7.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.7.0",
"v2.7.1",
"v2.7.2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2014-7848
- https://github.com/moodle/moodle/commit/0baf9763636aa4158a45ef2b539d2df0aa0bbd53
- https://github.com/moodle/moodle/commit/1993cc02b6b05f45ff1776813567c6b3f91480f4
- https://github.com/moodle/moodle/commit/84baa6b1417328ef7e4085d0112acc57167d15e4
- https://github.com/moodle/moodle
- https://moodle.org/mod/forum/discuss.php?d=275160
- https://web.archive.org/web/20150914064838/http://www.securitytracker.com/id/1031215
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-47287
- http://openwall.com/lists/oss-security/2014/11/17/11