GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-45vw-wh46-2vx8high8.7

Twig: Arbitrary PHP code execution via `_self.(<string>)` macro-reference compilation

Check your stack

The advisory, in context

Description

The obj.(expr) dynamic-attribute syntax (added in 3.15.0 as the replacement for the deprecated attribute() function) lets the attribute be an arbitrary expression. When the receiver is _self (or any {% import %} alias) and the parenthesised expression is a string literal, DotExpressionParser short-circuits to the macro-call path and concatenates the attacker-controlled string into a MacroReferenceExpression name with no identifier validation. MacroReferenceExpression::compile() then emits that name raw into the generated PHP source.

An attacker who can supply template source can inject arbitrary PHP into the compiled template and execute it at template-load time, before checkSecurity() is ever called. This is a complete bypass of SandboxExtension, including a globally-enabled sandbox with an empty SecurityPolicy allowlist.

Resolution

The parser now validates that the dynamic attribute resolves to a valid macro identifier before routing through MacroReferenceExpression, and the macro-reference compiler emits the name through a properly escaped path.

Credits

Twig would like to thank Claude Mythos Preview (via Project Glasswing) for reporting the issue and providing the fix.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

twig/twig Packagist
Ecosystem versions

From 3.15.0 before 3.26.0

Fixed in 3.26.0

15 explicitly affected versions

v3.15.0, v3.16.0, v3.17.0, v3.17.1, v3.18.0, v3.19.0, v3.20.0, v3.21.0, v3.21.1, v3.22.0, v3.22.1, v3.22.2, v3.23.0, v3.24.0, v3.25.0

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "3.15.0"
        },
        {
          "fixed": "3.26.0"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v3.15.0",
    "v3.16.0",
    "v3.17.0",
    "v3.17.1",
    "v3.18.0",
    "v3.19.0",
    "v3.20.0",
    "v3.21.0",
    "v3.21.1",
    "v3.22.0",
    "v3.22.1",
    "v3.22.2",
    "v3.23.0",
    "v3.24.0",
    "v3.25.0"
  ]
}

References