URL XSS vulnerability due to outdated jquery in CMS
The advisory, in context
Silverstripe silverstripe/framework through 4.11 allows XSS (issue 2 of 3).
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 1.0.0 before 1.11.3
Fixed in 1.11.3
79 explicitly affected versions
1.0.0, 1.0.1, 1.0.1-rc1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.1.0, 1.1.0-rc1, 1.1.0-rc2, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.10.0, 1.10.0-beta1, 1.10.0-rc1, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.11.0, 1.11.0-beta1, 1.11.0-rc1, 1.11.1, 1.11.2, 1.2.0, 1.2.0-beta1, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5, 1.2.6, 1.3.0, 1.3.0-rc1, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 1.4.0, 1.4.0-rc1, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 1.4.5, 1.5.0, 1.5.0-alpha1, 1.5.0-rc1, 1.5.0-rc2, 1.5.1, 1.5.2, 1.6.0, 1.6.0-beta1, 1.6.0-rc1, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.7.0, 1.7.0-beta1, 1.7.0-rc1, 1.7.1, 1.7.2, 1.7.3, 1.7.4, 1.8.0, 1.8.0-beta1, 1.8.0-rc1, 1.8.1, 1.9.0, 1.9.0-alpha1, 1.9.0-beta1, 1.9.0-rc1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.0.0"
},
{
"fixed": "1.11.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0.0",
"1.0.1",
"1.0.1-rc1",
"1.0.2",
"1.0.3",
"1.0.4",
"1.0.5",
"1.0.6",
"1.0.7",
"1.1.0",
"1.1.0-rc1",
"1.1.0-rc2",
"1.1.1",
"1.1.2",
"1.1.3",
"1.1.4",
"1.1.5",
"1.10.0",
"1.10.0-beta1",
"1.10.0-rc1",
"1.10.1",
"1.10.2",
"1.10.3",
"1.10.4",
"1.11.0",
"1.11.0-beta1",
"1.11.0-rc1",
"1.11.1",
"1.11.2",
"1.2.0",
"1.2.0-beta1",
"1.2.1",
"1.2.2",
"1.2.3",
"1.2.4",
"1.2.5",
"1.2.6",
"1.3.0",
"1.3.0-rc1",
"1.3.1",
"1.3.2",
"1.3.3",
"1.3.4",
"1.3.5",
"1.4.0",
"1.4.0-rc1",
"1.4.1",
"1.4.2",
"1.4.3",
"1.4.4",
"1.4.5",
"1.5.0",
"1.5.0-alpha1",
"1.5.0-rc1",
"1.5.0-rc2",
"1.5.1",
"1.5.2",
"1.6.0",
"1.6.0-beta1",
"1.6.0-rc1",
"1.6.1",
"1.6.2",
"1.6.3",
"1.6.4",
"1.7.0",
"1.7.0-beta1",
"1.7.0-rc1",
"1.7.1",
"1.7.2",
"1.7.3",
"1.7.4",
"1.8.0",
"1.8.0-beta1",
"1.8.0-rc1",
"1.8.1",
"1.9.0",
"1.9.0-alpha1",
"1.9.0-beta1",
"1.9.0-rc1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2022-38146
- https://forum.silverstripe.org/c/releases
- https://github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/admin/CVE-2022-38146.yaml
- https://www.silverstripe.org/blog/tag/release
- https://www.silverstripe.org/download/security-releases
- https://www.silverstripe.org/download/security-releases/CVE-2022-38146