GHSA-44m4-9cjp-j587high
IBX-1392: Image filenames sanitization
No CVE assignedCheck your stack
The advisory, in context
ezsystems/ezpublish-kernel versions 7.5.* before 7.5.26 are vulnerable to certain injection attacks and unauthorized access to some image files.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
ezsystems/ezpublish-kernel Packagist
Ecosystem versions
From 7.5.0 before 7.5.26
Fixed in 7.5.26
33 explicitly affected versions
v7.5.0, v7.5.1, v7.5.10, v7.5.11, v7.5.12, v7.5.13, v7.5.14, v7.5.15, v7.5.15.1, v7.5.15.2, v7.5.16, v7.5.17, v7.5.18, v7.5.19, v7.5.2, v7.5.20, v7.5.21, v7.5.22, v7.5.23, v7.5.24, v7.5.25, v7.5.3, v7.5.4, v7.5.5, v7.5.6, v7.5.6-rc1, v7.5.6.2, v7.5.7, v7.5.7-rc1, v7.5.7.1, v7.5.8, v7.5.9, v7.5.9.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.5.0"
},
{
"fixed": "7.5.26"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v7.5.0",
"v7.5.1",
"v7.5.10",
"v7.5.11",
"v7.5.12",
"v7.5.13",
"v7.5.14",
"v7.5.15",
"v7.5.15.1",
"v7.5.15.2",
"v7.5.16",
"v7.5.17",
"v7.5.18",
"v7.5.19",
"v7.5.2",
"v7.5.20",
"v7.5.21",
"v7.5.22",
"v7.5.23",
"v7.5.24",
"v7.5.25",
"v7.5.3",
"v7.5.4",
"v7.5.5",
"v7.5.6",
"v7.5.6-rc1",
"v7.5.6.2",
"v7.5.7",
"v7.5.7-rc1",
"v7.5.7.1",
"v7.5.8",
"v7.5.9",
"v7.5.9.1"
]
}