GHSA-4465-r2hg-v4rjmedium
CiviCRM SQL injection vulnerability via Quick Search API
The advisory, in context
The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote authenticated users to bypass the validation layer and conduct SQL injection attacks via a direct request to the "second layer" of the API, related to contact.getquick.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
civicrm/civicrm-core Packagist
Ecosystem versions
From 4.2.0 before 4.2.9
Fixed in 4.2.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.2.0"
},
{
"fixed": "4.2.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}civicrm/civicrm-core Packagist
Ecosystem versions
From 4.3.0 before 4.3.3
Fixed in 4.3.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.3.0"
},
{
"fixed": "4.3.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}