GHSA-4459-qrcc-vfcfmedium6.1
TYPO3 Cross-Site Scripting in Form Framework
No CVE assignedCheck your stack
The advisory, in context
Failing to properly encode user input, frontend forms handled by the form framework (system extension “form”) are vulnerable to cross-site scripting.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
typo3/cms-core Packagist
Ecosystem versions
From 8.5.0 before 8.7.23
Fixed in 8.7.23
16 explicitly affected versions
v8.7.10, v8.7.11, v8.7.12, v8.7.13, v8.7.14, v8.7.15, v8.7.16, v8.7.17, v8.7.18, v8.7.19, v8.7.20, v8.7.21, v8.7.22, v8.7.7, v8.7.8, v8.7.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "8.5.0"
},
{
"fixed": "8.7.23"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v8.7.10",
"v8.7.11",
"v8.7.12",
"v8.7.13",
"v8.7.14",
"v8.7.15",
"v8.7.16",
"v8.7.17",
"v8.7.18",
"v8.7.19",
"v8.7.20",
"v8.7.21",
"v8.7.22",
"v8.7.7",
"v8.7.8",
"v8.7.9"
]
}typo3/cms-core Packagist
Ecosystem versions
From 9.0.0 before 9.5.4
Fixed in 9.5.4
13 explicitly affected versions
v9.0.0, v9.1.0, v9.2.0, v9.2.1, v9.3.0, v9.3.1, v9.3.2, v9.3.3, v9.4.0, v9.5.0, v9.5.1, v9.5.2, v9.5.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "9.0.0"
},
{
"fixed": "9.5.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v9.0.0",
"v9.1.0",
"v9.2.0",
"v9.2.1",
"v9.3.0",
"v9.3.1",
"v9.3.2",
"v9.3.3",
"v9.4.0",
"v9.5.0",
"v9.5.1",
"v9.5.2",
"v9.5.3"
]
}References
- https://github.com/TYPO3-CMS/core/commit/3b8b8b4416b921df4ccc7c5b4a8e9a069562be35
- https://github.com/TYPO3-CMS/core/commit/a0e917008320e24c26780ba385fbfe738fcd45b9
- https://github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms-core/2019-01-22-6.yaml
- https://github.com/TYPO3-CMS/core
- https://typo3.org/security/advisory/typo3-core-sa-2019-007