GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-43w4-4j3c-jx29low2.0

Winter CMS Stored XSS through Backend ColorPicker FormWidget

Check your stack

The advisory, in context

Impact

Users with access to backend forms that include a ColorPicker FormWidget can provide a value that would then be rendered unescaped in the backend form, potentially allowing for a stored XSS attack.

By default, only the Brand Settings (backend.manage_branding) and Mail Brand Settings (system.manage_mail_templates) forms include the colorpicker formwidget, however it is also common for theme's to include it on their Theme Customization (cms.manage_theme_options) form.

Although this was a security issue, it's important to note that its severity is relatively low. To exploit the vulnerability, an attacker would already need to have trusted access to the Winter CMS backend and they would then need to convince a user with higher privileges than them to visit an affected Form in the backend.

These two factors limit the potential harm of this vulnerability. That being said, all users are advised to update to the latest version (1.2.4) to ensure their systems remain secure.

Patches

This issue has been patched in v1.2.4.

Workarounds

Apply https://github.com/wintercms/winter/commit/517f65dfae679b57575b047de13c5af48915a5ba manually if unable to upgrade to v1.2.4.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

Earlier releases before 1.2.4

Fixed in 1.2.4

17 explicitly affected versions

v1.0.473, v1.0.474, v1.0.475, v1.1.10, v1.1.11, v1.1.2, v1.1.3, v1.1.4, v1.1.5, v1.1.6, v1.1.7, v1.1.8, v1.1.9, v1.2.0, v1.2.1, v1.2.2, v1.2.3

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "1.2.4"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v1.0.473",
    "v1.0.474",
    "v1.0.475",
    "v1.1.10",
    "v1.1.11",
    "v1.1.2",
    "v1.1.3",
    "v1.1.4",
    "v1.1.5",
    "v1.1.6",
    "v1.1.7",
    "v1.1.8",
    "v1.1.9",
    "v1.2.0",
    "v1.2.1",
    "v1.2.2",
    "v1.2.3"
  ]
}

References