GHSA-43f8-p5w3-5m25medium
vrana/adminer vulnerable to SSRF by connecting to privileged ports
The advisory, in context
Impact
All users are affected.
Patches
- Unsuccessfully patched by 0fae40fb, included in version 4.4.0.
- Patched by 35bfaa75, included in version 4.7.8.
Workarounds
Protect access to Adminer also by other means, e.g. by HTTP password, IP address limiting or by OTP plugin.
References
- http://hyp3rlinx.altervista.org/advisories/ADMINER-UNAUTHENTICATED-SERVER-SIDE-REQUEST-FORGERY.txt
- https://sourceforge.net/p/adminer/bugs-and-features/769/
- https://gusralph.info/adminer-ssrf-bypass-cve-2018-7667/ (CVE-2020-28654)
For more information
If you have any questions or comments about this advisory:
- Comment at 35bfaa75.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
vrana/adminer Packagist
Ecosystem versions
Earlier releases before 4.7.8
Fixed in 4.7.8
22 explicitly affected versions
v4.2.0, v4.2.1, v4.2.2, v4.2.3, v4.2.4, v4.2.5, v4.3.0, v4.3.1, v4.4.0, v4.5.0, v4.6.0, v4.6.1, v4.6.2, v4.6.3, v4.7.0, v4.7.1, v4.7.2, v4.7.3, v4.7.4, v4.7.5, v4.7.6, v4.7.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "4.7.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.2.0",
"v4.2.1",
"v4.2.2",
"v4.2.3",
"v4.2.4",
"v4.2.5",
"v4.3.0",
"v4.3.1",
"v4.4.0",
"v4.5.0",
"v4.6.0",
"v4.6.1",
"v4.6.2",
"v4.6.3",
"v4.7.0",
"v4.7.1",
"v4.7.2",
"v4.7.3",
"v4.7.4",
"v4.7.5",
"v4.7.6",
"v4.7.7"
]
}References
- https://github.com/vrana/adminer/security/advisories/GHSA-43f8-p5w3-5m25
- https://github.com/vrana/adminer/commit/35bfaa75
- https://gusralph.info/adminer-ssrf-bypass-cve-2018-7667
- https://sourceforge.net/p/adminer/bugs-and-features/769
- http://hyp3rlinx.altervista.org/advisories/ADMINER-UNAUTHENTICATED-SERVER-SIDE-REQUEST-FORGERY.txt