Mautic vulnerable to secret data extraction via elfinder
The advisory, in context
Summary
A user with administrator rights can change the configuration of the mautic application and extract secrets that are not normally available.
Impact
An administrator who usually does not have access to certain parameters, such as database credentials, can disclose them.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 4.4.0 before 4.4.17
Fixed in 4.4.17
14 explicitly affected versions
4.4.0, 4.4.1, 4.4.10, 4.4.11, 4.4.12, 4.4.13, 4.4.2, 4.4.3, 4.4.4, 4.4.5, 4.4.6, 4.4.7, 4.4.8, 4.4.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.4.0"
},
{
"fixed": "4.4.17"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.4.0",
"4.4.1",
"4.4.10",
"4.4.11",
"4.4.12",
"4.4.13",
"4.4.2",
"4.4.3",
"4.4.4",
"4.4.5",
"4.4.6",
"4.4.7",
"4.4.8",
"4.4.9"
]
}From 5.0.0-alpha before 5.2.8
Fixed in 5.2.8
21 explicitly affected versions
5.0.0, 5.0.0-alpha, 5.0.0-alpha1, 5.0.0-beta1, 5.0.0-beta2, 5.0.0-rc1, 5.0.0-rc2, 5.0.1, 5.0.2, 5.0.3, 5.0.4, 5.1.0, 5.1.1, 5.2.0, 5.2.1, 5.2.2, 5.2.3, 5.2.4, 5.2.5, 5.2.6, 5.2.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.0.0-alpha"
},
{
"fixed": "5.2.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.0.0",
"5.0.0-alpha",
"5.0.0-alpha1",
"5.0.0-beta1",
"5.0.0-beta2",
"5.0.0-rc1",
"5.0.0-rc2",
"5.0.1",
"5.0.2",
"5.0.3",
"5.0.4",
"5.1.0",
"5.1.1",
"5.2.0",
"5.2.1",
"5.2.2",
"5.2.3",
"5.2.4",
"5.2.5",
"5.2.6",
"5.2.7"
]
}From 6.0.0-alpha before 6.0.5
Fixed in 6.0.5
8 explicitly affected versions
6.0.0, 6.0.0-alpha, 6.0.0-beta2, 6.0.0-rc, 6.0.1, 6.0.2, 6.0.3, 6.0.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.0.0-alpha"
},
{
"fixed": "6.0.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"6.0.0",
"6.0.0-alpha",
"6.0.0-beta2",
"6.0.0-rc",
"6.0.1",
"6.0.2",
"6.0.3",
"6.0.4"
]
}References
- https://github.com/mautic/mautic/security/advisories/GHSA-438m-6mhw-hq5w
- https://nvd.nist.gov/vuln/detail/CVE-2025-9822
- https://github.com/mautic/mautic/commit/882c2c5be646e36f7b91e7c4b24f71aafa617cd5
- https://github.com/mautic/mautic/commit/a310b1933de7cfefec03382a4d8c0d9dbbaa0600
- https://github.com/mautic/mautic