GHSA-3rqj-jchw-9cc7medium
Moodle Authentication Bypass in Question-Bank
The advisory, in context
The question-bank functionality in Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3 allows remote authenticated users to bypass intended capability requirements and save questions via a save_question action.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
moodle/moodle Packagist
Ecosystem versions
From 2.1 before 2.1.6
Fixed in 2.1.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.1"
},
{
"fixed": "2.1.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}moodle/moodle Packagist
Ecosystem versions
From 2.2 before 2.2.3
Fixed in 2.2.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.2"
},
{
"fixed": "2.2.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2012-2356
- https://github.com/moodle/moodle/commit/0f83dd10a1d013e77906c7be4560126bb14c6b5c
- https://github.com/moodle/moodle/commit/29e247e44e983f230f248192ffac8e7b7abe37fd
- https://github.com/moodle/moodle/commit/51c5e6057c67687f5d872f8a228cfea275abf576
- https://github.com/moodle/moodle
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-32239
- http://openwall.com/lists/oss-security/2012/05/23/2