XSS vulnerability that affects bootstrap
The advisory, in context
In Bootstrap before 3.4.0, XSS is possible in the tooltip data-viewport attribute.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 3.4.0
Fixed in 3.4.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.4.0"
}
],
"type": "SEMVER"
}
],
"versions": []
}Earlier releases before 3.4.0
Fixed in 3.4.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.4.0"
}
],
"type": "SEMVER"
}
],
"versions": []
}Earlier releases before 3.4.0
Fixed in 3.4.0
20 explicitly affected versions
v2.2.2, v2.3.0, v2.3.1, v2.3.2, v3.0.0, v3.0.0-rc.2, v3.0.0-rc1, v3.0.1, v3.0.2, v3.0.3, v3.1.0, v3.1.1, v3.2.0, v3.3.0, v3.3.1, v3.3.2, v3.3.4, v3.3.5, v3.3.6, v3.3.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.4.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.2.2",
"v2.3.0",
"v2.3.1",
"v2.3.2",
"v3.0.0",
"v3.0.0-rc.2",
"v3.0.0-rc1",
"v3.0.1",
"v3.0.2",
"v3.0.3",
"v3.1.0",
"v3.1.1",
"v3.2.0",
"v3.3.0",
"v3.3.1",
"v3.3.2",
"v3.3.4",
"v3.3.5",
"v3.3.6",
"v3.3.7"
]
}Earlier releases before 3.4.0
Fixed in 3.4.0
33 explicitly affected versions
1.3.0, 2.0.2, 2.1.1, 2.2.1, 2.2.2, 2.2.2-1, 2.3.0, 2.3.1, 2.3.1-1, 2.3.2, 3.0.0, 3.0.0-rc.2, 3.0.0-rc1, 3.0.1, 3.0.2, 3.0.3, 3.1.0, 3.1.1, 3.1.1-1, 3.1.1-2, 3.2.0, 3.2.0-1, 3.2.0-2, 3.3.0, 3.3.1, 3.3.2, 3.3.2-1, 3.3.2-2, 3.3.4, 3.3.5, 3.3.6, 3.3.7, 3.3.7-1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.4.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.3.0",
"2.0.2",
"2.1.1",
"2.2.1",
"2.2.2",
"2.2.2-1",
"2.3.0",
"2.3.1",
"2.3.1-1",
"2.3.2",
"3.0.0",
"3.0.0-rc.2",
"3.0.0-rc1",
"3.0.1",
"3.0.2",
"3.0.3",
"3.1.0",
"3.1.1",
"3.1.1-1",
"3.1.1-2",
"3.2.0",
"3.2.0-1",
"3.2.0-2",
"3.3.0",
"3.3.1",
"3.3.2",
"3.3.2-1",
"3.3.2-2",
"3.3.4",
"3.3.5",
"3.3.6",
"3.3.7",
"3.3.7-1"
]
}Earlier releases before 3.4.0
Fixed in 3.4.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.4.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}Earlier releases before 3.4.0
Fixed in 3.4.0
57 explicitly affected versions
1.2.0, 1.2.1, 1.3.0, 1.3.1, 1.3.2, 1.4.0, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.3.1, 2.0.4.0, 2.0.4.1, 2.0.4.2, 2.1.0.0, 2.1.0.1, 2.1.1.0, 2.2.1.0, 2.2.1.1, 2.2.2.0, 2.3.0.0, 2.3.0.1, 2.3.1.0, 2.3.1.2, 2.3.1.3, 2.3.2.0, 2.3.2.1, 2.3.2.2, 3.0.0.0, 3.0.0.0.rc, 3.0.0.0.rc2, 3.0.1.0, 3.0.1.0.rc, 3.0.2.0, 3.0.2.1, 3.0.3.0, 3.1.0.0, 3.1.0.1, 3.1.0.2, 3.1.1.0, 3.1.1.1, 3.2.0.4, 3.3.0.0, 3.3.0.1, 3.3.1.0, 3.3.2.0, 3.3.2.1, 3.3.3, 3.3.4.1, 3.3.5, 3.3.5.1, 3.3.6, 3.3.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.4.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.2.0",
"1.2.1",
"1.3.0",
"1.3.1",
"1.3.2",
"1.4.0",
"1.4.1",
"1.4.2",
"1.4.3",
"1.4.4",
"2.0.0",
"2.0.1",
"2.0.2",
"2.0.3",
"2.0.3.1",
"2.0.4.0",
"2.0.4.1",
"2.0.4.2",
"2.1.0.0",
"2.1.0.1",
"2.1.1.0",
"2.2.1.0",
"2.2.1.1",
"2.2.2.0",
"2.3.0.0",
"2.3.0.1",
"2.3.1.0",
"2.3.1.2",
"2.3.1.3",
"2.3.2.0",
"2.3.2.1",
"2.3.2.2",
"3.0.0.0",
"3.0.0.0.rc",
"3.0.0.0.rc2",
"3.0.1.0",
"3.0.1.0.rc",
"3.0.2.0",
"3.0.2.1",
"3.0.3.0",
"3.1.0.0",
"3.1.0.1",
"3.1.0.2",
"3.1.1.0",
"3.1.1.1",
"3.2.0.4",
"3.3.0.0",
"3.3.0.1",
"3.3.1.0",
"3.3.2.0",
"3.3.2.1",
"3.3.3",
"3.3.4.1",
"3.3.5",
"3.3.5.1",
"3.3.6",
"3.3.7"
]
}Earlier releases before 3.4.0
Fixed in 3.4.0
19 explicitly affected versions
1.0.0, 2.3.1, 2.3.2, 3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.1.0, 3.1.1, 3.2.0, 3.3.0, 3.3.1, 3.3.2, 3.3.4, 3.3.5, 3.3.6, 3.3.6-jQuery3, 3.3.6.1, 3.3.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.4.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0.0",
"2.3.1",
"2.3.2",
"3.0.0",
"3.0.1",
"3.0.2",
"3.0.3",
"3.1.0",
"3.1.1",
"3.2.0",
"3.3.0",
"3.3.1",
"3.3.2",
"3.3.4",
"3.3.5",
"3.3.6",
"3.3.6-jQuery3",
"3.3.6.1",
"3.3.7"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2018-20676
- https://github.com/twbs/bootstrap/issues/27915#issuecomment-452196628
- https://github.com/twbs/bootstrap/issues/27915#issuecomment-452140906
- https://github.com/twbs/bootstrap/issues/27044
- https://github.com/twbs/bootstrap/pull/27047
- https://github.com/twbs/bootstrap/commit/2a5ba23ce8f041f3548317acc992ed8a736b609d
- https://lists.apache.org/thread.html/rd0e44e8ef71eeaaa3cf3d1b8b41eb25894372e2995ec908ce7624d26@%3Ccommits.pulsar.apache.org%3E
- https://github.com/twbs/bootstrap
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/bootstrap/CVE-2018-20676.yml
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/bootstrap-sass/CVE-2018-20676.yml
- https://blog.getbootstrap.com/2018/12/13/bootstrap-3-4-0
- https://access.redhat.com/errata/RHSA-2020:0133
- https://access.redhat.com/errata/RHSA-2020:0132
- https://access.redhat.com/errata/RHSA-2019:3023
- https://access.redhat.com/errata/RHSA-2019:1456
- https://access.redhat.com/errata/RHBA-2019:1570
- https://access.redhat.com/errata/RHBA-2019:1076