GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-3f89-869f-5w76medium5.9

Cross-site scripting from dynamic options in the multiselect field

Check your stack

The advisory, in context

Introduction

Cross-site scripting (XSS) is a type of vulnerability that allows to execute any kind of JavaScript code inside the Panel session of the same or other users. In the Panel, a harmful script can for example trigger requests to Kirby's API with the permissions of the victim.

Such vulnerabilities are critical if you might have potential attackers in your group of authenticated Panel users. They can escalate their privileges if they get access to the Panel session of an admin user. Depending on your site, other JavaScript-powered attacks are possible.

Impact

The multiselect field allows to select tags from an autocompleted list. Unfortunately, the Panel in Kirby 3.5 used HTML rendering for the raw option value.

This allowed attackers with influence on the options source (e.g. content of sibling pages or an API endpoint) to inject HTML code. If a page in the Panel that uses the manipulated multiselect options was visited by a victim and the victim opened the autocomplete dropdown, the victim's browser will then have rendered this malicious HTML code.

You are not affected by this vulnerability if you don't use the multiselect field or only use it with options that cannot be manipulated by attackers.

Patches

The problem has been patched in Kirby 3.5.8.1. Please update to this or a later version to fix the vulnerability.

Workarounds

We recommend to update to the patch release. If you cannot update immediately, you can work around the issue by disabling the multiselect field. This can be done by uncommenting this field from all your blueprints.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

getkirby/cms Packagist
Ecosystem versions

Earlier releases before 3.5.8.1

Fixed in 3.5.8.1

85 explicitly affected versions

3.0.0, 3.0.1, 3.0.1-rc.1, 3.0.2, 3.0.2-rc.1, 3.0.3, 3.0.3-rc.1, 3.0.3-rc.2, 3.0.3-rc.3, 3.1.0, 3.1.0-rc.1, 3.1.1, 3.1.2, 3.1.2-rc.1, 3.1.3, 3.1.3-rc.1, 3.1.4, 3.1.4-rc.1, 3.2.0, 3.2.0-rc.1, 3.2.0-rc.2, 3.2.0-rc.3, 3.2.0-rc.4, 3.2.1, 3.2.1-rc.1, 3.2.2, 3.2.3, 3.2.3-rc.1, 3.2.4, 3.2.4-rc.1, 3.2.5, 3.2.5-rc.1, 3.2.5-rc.2, 3.3.0, 3.3.0-rc.1, 3.3.0-rc.2, 3.3.0-rc.3, 3.3.0-rc.4, 3.3.0-rc.5, 3.3.1, 3.3.1-rc.1, 3.3.2, 3.3.2-rc.1, 3.3.3, 3.3.3-rc.1, 3.3.4, 3.3.4-rc.1, 3.3.5, 3.3.5-rc.1, 3.3.6, 3.4.0, 3.4.0-rc.1, 3.4.0-rc.2, 3.4.0-rc.3, 3.4.1, 3.4.1-rc.1, 3.4.2, 3.4.3, 3.4.3-rc.1, 3.4.4, 3.4.4-rc.1, 3.4.5, 3.5.0, 3.5.0-rc.1, 3.5.0-rc.2, 3.5.0-rc.3, 3.5.0-rc.4, 3.5.0-rc.5, 3.5.0-rc.6, 3.5.0-rc.7, 3.5.1, 3.5.1-rc.1, 3.5.2, 3.5.2-rc.1, 3.5.3, 3.5.3.1, 3.5.4, 3.5.5, 3.5.5-rc.1, 3.5.6, 3.5.6-rc.1, 3.5.7, 3.5.7-rc.1, 3.5.7.1, 3.5.8

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "3.5.8.1"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "3.0.0",
    "3.0.1",
    "3.0.1-rc.1",
    "3.0.2",
    "3.0.2-rc.1",
    "3.0.3",
    "3.0.3-rc.1",
    "3.0.3-rc.2",
    "3.0.3-rc.3",
    "3.1.0",
    "3.1.0-rc.1",
    "3.1.1",
    "3.1.2",
    "3.1.2-rc.1",
    "3.1.3",
    "3.1.3-rc.1",
    "3.1.4",
    "3.1.4-rc.1",
    "3.2.0",
    "3.2.0-rc.1",
    "3.2.0-rc.2",
    "3.2.0-rc.3",
    "3.2.0-rc.4",
    "3.2.1",
    "3.2.1-rc.1",
    "3.2.2",
    "3.2.3",
    "3.2.3-rc.1",
    "3.2.4",
    "3.2.4-rc.1",
    "3.2.5",
    "3.2.5-rc.1",
    "3.2.5-rc.2",
    "3.3.0",
    "3.3.0-rc.1",
    "3.3.0-rc.2",
    "3.3.0-rc.3",
    "3.3.0-rc.4",
    "3.3.0-rc.5",
    "3.3.1",
    "3.3.1-rc.1",
    "3.3.2",
    "3.3.2-rc.1",
    "3.3.3",
    "3.3.3-rc.1",
    "3.3.4",
    "3.3.4-rc.1",
    "3.3.5",
    "3.3.5-rc.1",
    "3.3.6",
    "3.4.0",
    "3.4.0-rc.1",
    "3.4.0-rc.2",
    "3.4.0-rc.3",
    "3.4.1",
    "3.4.1-rc.1",
    "3.4.2",
    "3.4.3",
    "3.4.3-rc.1",
    "3.4.4",
    "3.4.4-rc.1",
    "3.4.5",
    "3.5.0",
    "3.5.0-rc.1",
    "3.5.0-rc.2",
    "3.5.0-rc.3",
    "3.5.0-rc.4",
    "3.5.0-rc.5",
    "3.5.0-rc.6",
    "3.5.0-rc.7",
    "3.5.1",
    "3.5.1-rc.1",
    "3.5.2",
    "3.5.2-rc.1",
    "3.5.3",
    "3.5.3.1",
    "3.5.4",
    "3.5.5",
    "3.5.5-rc.1",
    "3.5.6",
    "3.5.6-rc.1",
    "3.5.7",
    "3.5.7-rc.1",
    "3.5.7.1",
    "3.5.8"
  ]
}

References