GHSA-3cvm-7wrh-qrf9medium5.4
Craft CMS vulnerable to stored Cross-site Scripting via /admin/settings/fields page
The advisory, in context
Craft CMS 4.2.0.1 is vulnerable to stored a cross-site scripting (XSS) via /admin/settings/fields page.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
craftcms/cms Packagist
Ecosystem versions
From 4.0.0-RC1 before 4.2.1
Fixed in 4.2.1
24 explicitly affected versions
4.0.0, 4.0.0-RC1, 4.0.0-RC2, 4.0.0-RC3, 4.0.0.1, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.0.5, 4.0.5.1, 4.0.5.2, 4.0.6, 4.1.0, 4.1.0.1, 4.1.0.2, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.1.4.1, 4.2.0, 4.2.0.1, 4.2.0.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0.0-RC1"
},
{
"fixed": "4.2.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.0",
"4.0.0-RC1",
"4.0.0-RC2",
"4.0.0-RC3",
"4.0.0.1",
"4.0.1",
"4.0.2",
"4.0.3",
"4.0.4",
"4.0.5",
"4.0.5.1",
"4.0.5.2",
"4.0.6",
"4.1.0",
"4.1.0.1",
"4.1.0.2",
"4.1.1",
"4.1.2",
"4.1.3",
"4.1.4",
"4.1.4.1",
"4.2.0",
"4.2.0.1",
"4.2.0.2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2022-37247
- https://github.com/craftcms/cms/commit/cedeba0609e4b173cd584dae7f33c5f713f19627
- https://github.com/craftcms/cms
- https://github.com/craftcms/cms/blob/3.7.55.2/src/helpers/Cp.php
- https://github.com/craftcms/cms/blob/4.0.0-RC1/src/helpers/Cp.php
- https://labs.integrity.pt/advisories/cve-2022-37247