XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic
The advisory, in context
Impact
This is a cross-site scripting vulnerability which affects every version of Mautic and could allow an attacker unauthorised administrator level access to Mautic.
This vulnerability was reported by Naveen Sunkavally at Horizon3.ai.
Patches
Upgrade to 3.2.4 or 2.16.5.
Link to patch for 2.x versions: https://github.com/mautic/mautic/compare/2.16.4...2.16.5.diff
Link to patch for 3.x versions: https://github.com/mautic/mautic/compare/3.2.2...3.2.4.diff
Workarounds
None
For more information
If you have any questions or comments about this advisory:
- Post in https://forum.mautic.org/c/support
- Email us at security@mautic.org
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 3.0.0 before 3.2.4
Fixed in 3.2.4
16 explicitly affected versions
3.0.0, 3.0.1, 3.0.2, 3.0.2-rc, 3.1.0, 3.1.0-rc, 3.1.1, 3.1.1-rc, 3.1.2, 3.1.2-rc, 3.2.0, 3.2.0-rc, 3.2.1, 3.2.2, 3.2.2-rc, 3.2.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.2.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.0.0",
"3.0.1",
"3.0.2",
"3.0.2-rc",
"3.1.0",
"3.1.0-rc",
"3.1.1",
"3.1.1-rc",
"3.1.2",
"3.1.2-rc",
"3.2.0",
"3.2.0-rc",
"3.2.1",
"3.2.2",
"3.2.2-rc",
"3.2.3"
]
}From 2.0.0 before 2.16.5
Fixed in 2.16.5
58 explicitly affected versions
2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.10.0, 2.10.0-beta, 2.10.1, 2.11.0, 2.11.0-beta, 2.12.0, 2.12.0-beta, 2.12.1, 2.12.1-beta, 2.12.2, 2.12.2-beta, 2.13.0, 2.13.0-beta, 2.13.1, 2.14.0, 2.14.0-beta, 2.14.1, 2.14.1-beta, 2.14.2, 2.14.2-beta, 2.15.0, 2.15.0-beta, 2.15.1, 2.15.1-beta, 2.15.2, 2.15.2-beta, 2.15.3, 2.15.3-beta, 2.16.0, 2.16.0-beta, 2.16.1, 2.16.1-beta, 2.16.2, 2.16.2-beta, 2.16.3, 2.16.3-beta, 2.16.4, 2.2.0, 2.2.1, 2.3.0, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.8.2, 2.9.0, 2.9.0-beta, 2.9.1, 2.9.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.16.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.0.0",
"2.0.1",
"2.1.0",
"2.1.1",
"2.10.0",
"2.10.0-beta",
"2.10.1",
"2.11.0",
"2.11.0-beta",
"2.12.0",
"2.12.0-beta",
"2.12.1",
"2.12.1-beta",
"2.12.2",
"2.12.2-beta",
"2.13.0",
"2.13.0-beta",
"2.13.1",
"2.14.0",
"2.14.0-beta",
"2.14.1",
"2.14.1-beta",
"2.14.2",
"2.14.2-beta",
"2.15.0",
"2.15.0-beta",
"2.15.1",
"2.15.1-beta",
"2.15.2",
"2.15.2-beta",
"2.15.3",
"2.15.3-beta",
"2.16.0",
"2.16.0-beta",
"2.16.1",
"2.16.1-beta",
"2.16.2",
"2.16.2-beta",
"2.16.3",
"2.16.3-beta",
"2.16.4",
"2.2.0",
"2.2.1",
"2.3.0",
"2.4.0",
"2.5.0",
"2.5.1",
"2.6.0",
"2.6.1",
"2.7.0",
"2.7.1",
"2.8.0",
"2.8.1",
"2.8.2",
"2.9.0",
"2.9.0-beta",
"2.9.1",
"2.9.2"
]
}References
- https://github.com/mautic/mautic/security/advisories/GHSA-39wj-j3jc-858m
- https://nvd.nist.gov/vuln/detail/CVE-2020-35124
- https://github.com/mautic/mautic/commit/20c5dc39b62164f6922ce53ea42cbb4ccec64e57
- https://forum.mautic.org/c/announcements/16
- https://github.com/FriendsOfPHP/security-advisories/blob/master/mautic/core/CVE-2020-35124.yaml
- https://packagist.org/packages/mautic/core
- https://www.horizon3.ai/disclosures/mautic-unauth-xss-to-rce
- https://www.mautic.org/blog/community/security-release-all-versions-mautic-prior-2-16-5-and-3-2-4