GHSA-394m-vxwj-363jmedium6.5
YetiForceCRM Directory Traversal vulnerability
The advisory, in context
Directory Traversal vulnerability in YetiForceCompany YetiForceCRM versions 6.4.0 and before allows a remote authenticated attacker to obtain sensitive information via the license parameter in the LibraryLicense.php component.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
yetiforce/yetiforce-crm Packagist
Ecosystem versions
Earlier releases before 6.5.0
Fixed in 6.5.0
18 explicitly affected versions
4.0.0, 4.1.0, 4.2.0, 4.3.0, 4.4.0, 4.4.0_RC1, 4.4.0_RC2, 4.4.0_RC3, 5.0.0, 5.1.0, 5.2.0, 5.3.0, 6.0.0, 6.0.0a, 6.1.0, 6.2.0, 6.3.0, 6.4.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "6.5.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.0",
"4.1.0",
"4.2.0",
"4.3.0",
"4.4.0",
"4.4.0_RC1",
"4.4.0_RC2",
"4.4.0_RC3",
"5.0.0",
"5.1.0",
"5.2.0",
"5.3.0",
"6.0.0",
"6.0.0a",
"6.1.0",
"6.2.0",
"6.3.0",
"6.4.0"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2023-49508
- https://github.com/YetiForceCompany/YetiForceCRM/commit/ba3a348aa6ecdf0a1d8b289cbb679bebcda7a132
- https://github.com/YetiForceCompany/YetiForceCRM
- https://github.com/c4v4r0n/Research/tree/main/CVE-2023-49508
- https://huntr.com/bounties/29ed641d-eb03-4532-aed4-f96e11f78983