brotkrueml/schema fails to properly encode user input for output in HTML context, leading to XSS
The advisory, in context
The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 2.0.0 before 2.5.1
Fixed in 2.5.1
10 explicitly affected versions
v2.0.0, v2.0.1, v2.0.2, v2.1.0, v2.2.0, v2.2.1, v2.2.2, v2.3.0, v2.4.0, v2.5.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.5.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.0.0",
"v2.0.1",
"v2.0.2",
"v2.1.0",
"v2.2.0",
"v2.2.1",
"v2.2.2",
"v2.3.0",
"v2.4.0",
"v2.5.0"
]
}Earlier releases before 1.13.1
Fixed in 1.13.1
33 explicitly affected versions
v0.1.0, v0.2.0, v0.3.0, v0.4.0, v0.5.0, v0.6.0, v0.7.0, v0.8.0, v0.8.1, v0.9.0, v1.0.0, v1.1.0, v1.10.0, v1.11.0, v1.11.1, v1.12.0, v1.12.1, v1.13.0, v1.2.0, v1.3.0, v1.3.1, v1.4.0, v1.4.1, v1.4.2, v1.5.0, v1.5.1, v1.5.2, v1.6.0, v1.7.0, v1.7.1, v1.7.2, v1.8.0, v1.9.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.13.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v0.1.0",
"v0.2.0",
"v0.3.0",
"v0.4.0",
"v0.5.0",
"v0.6.0",
"v0.7.0",
"v0.8.0",
"v0.8.1",
"v0.9.0",
"v1.0.0",
"v1.1.0",
"v1.10.0",
"v1.11.0",
"v1.11.1",
"v1.12.0",
"v1.12.1",
"v1.13.0",
"v1.2.0",
"v1.3.0",
"v1.3.1",
"v1.4.0",
"v1.4.1",
"v1.4.2",
"v1.5.0",
"v1.5.1",
"v1.5.2",
"v1.6.0",
"v1.7.0",
"v1.7.1",
"v1.7.2",
"v1.8.0",
"v1.9.0"
]
}